[ главная ]   [ рейтинг статей ]   [ справочник радиолюбителя ]   [ новости мира ИТ ]



Ответов: 0
25-02-12 07:01







   Web - программирование
PHP


ASP






XML



CSS

SSI





   Программирование под ОС











   Web - технологии








   Базы Данных









   Графика






Данные




Web - технологии / Сети /

Базовая конфигурация роутера для доступа в Интернет

Источник: www.ciscolab.ru

Этот документ описывает как использовать Командный Интерфейс роутера (Command Line Interface, CLI) чтобы установить базовую конфигурацию. Он включает назначение IP адресов, установку маршрута по умолчанию, создание статического и динамического NAT (трасляция внутренних адресов хостов), задание имени роутера, приветственного сообщения (banner), создание пользовательского аккаунта и установку пароля доступа к роутеру по сети.

Сетевая диаграмма показана на рисунке

 

alt
 

В качестве роутера используется Cisco 3640 c IOS 12.4.


Фрагмент конфигурации 3640

<!--code1-->
<!--ecode1-->
!--- Создаем пользовательский аккаунт sdmsdm со всеми привилениями
username sdmsdm privilege 15 password 0 sdmsdm
!
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!

!--- Интерфейс LAN конфигурируется IP адресом из приватного диапазона.
interface FastEthernet1/0
ip address 172.16.1.2 255.255.255.0

!--- Трафик который приходит на этот интефейс является объектом для трансляции (NAT)
ip nat inside

duplex auto
speed auto
!

!--- Это WAN интерфейс, конфигурируется маршрутизируемым (публичным) IP адресом.
interface Serial2/0
ip address 192.168.1.1 255.255.255.0

!--- Обозначим, что этот интерфейс приемником для трафика, который подвергся NAT
ip nat outside

!--- Далее следует конфигурация для динамического NAT.
!
!--- Определим пул внешних IP адресов для NAT.
ip nat pool pool1 192.168.1.3 192.168.1.10 netmask 255.255.255.0

!--- Для того, чтобы разрешить NAT для внутренних SRC адресов, указываем, что трафик от хостов
!---которые попадают под access list 1, транслируются в адресный пул с именем pool1
ip nat inside source list 1 pool pool1


!--- Access list 1 дозволяет транслировать только сеть 172.16.1.0
access-list 1 permit 172.16.1.0 0.0.0.255

!--- Это конфигурация для статического NAT

!--- Для того, чтобы транслировать пакеты между внутренним IP адресом 172.16.1.1 TCP порт 80
!--- и преобразованным IP адресом 192.168.1.1 TCP порт 500.
ip nat inside source static tcp 172.16.1.1 80 192.168.1.3 500 extendable

!--- Маршрут по умолчанию указывает на 192.168.1.2.
ip route 0.0.0.0 0.0.0.0 192.168.1.2

!--- Статический путь указывает тоже на 192.168.1.2.
ip route 10.1.1.0 255.255.255.0 192.168.1.2
!
line con 0
line aux 0

!--- Разрешает telnet к роутеру и устанавливаем пароль sdmsdm.
line vty 0 4
password sdmsdm
login
!
!
end



Комментарии

vdacmfshzp
30-07-2011   
XhqqgL , [url=http://mqnbaxghpeat.com/]mqnbaxghpeat[/url], [link=http://xbddhjdenwit.com/]xbddhjdenwit[/link], http://zxxjnferyfdb.com/

hmwpzspiq
27-07-2011   
PtsxrJ <a href="http://xzibmwhtpubf.com/">xzibmwhtpubf</a>

mnuwstqcg
26-07-2011   
xjRIF2 <a href="http://bjuchncpreez.com/">bjuchncpreez</a>

Sandra
25-07-2011   
None can doubt the vreicaty of this article.

 Ваш комментарий к данному материалу будет интересен нам и нашим читателям!



Последние статьи: Web - технологии / Сети /

Будущие интернет-каналы могут быть созданы на основе нанотрубок
30-01-2011   

Американские исследователи из Корнельского университета говорят, что углеродные нанотрубки способны передавать и принимать фотоны света в наномасштабах точно также, как радиостанции работают с радиоволнами.

... подробнее

Кол. просмотров: общее - 3975 сегодня - 0

Ботнет
15-03-2010   

В статье речь пойдет о том, что такое зомби-сети, или ботнеты, как они формируются, кто и как наживается с их помощью, а также о том, каковы тенденции развития ботнетов... подробнее

Кол. просмотров: общее - 3012 сегодня - 1

Как работает NAT
15-03-2010   

Если Вы читаете этот документ, то скорее всего вы подсоединены к Интернету, и используете трансляцию сетевых адресов (Network Address Translation, NAT) прямо сейчас! Интернет стал настолько огромным, чем кто-либо мог себе представить... подробнее

Кол. просмотров: общее - 3083 сегодня - 2

Построение безопасных сетей на основе VPN
15-03-2010   

В современных условиях развития информационных технологий, преимущества создания виртуальных частных сетей неоспоримы. Но прежде чем перечислить наиболее очевидные и полезные способы организации виртуальных частных сетей... подробнее

Кол. просмотров: общее - 3290 сегодня - 1

NAS – сетевая система хранения данных
15-03-2010   

NAS (англ. Network Attached Storage) – сетевая система хранения данных. Сетевые хранилища представляют собой внешние жёсткие диски... подробнее

Кол. просмотров: общее - 2847 сегодня - 0



  WWW.COMPROG.RU - 2009-2012 | Designed and Powered by Zaipov Renat | Projects