[ главная ]   [ рейтинг статей ]   [ справочник радиолюбителя ]   [ новости мира ИТ ]



Ответов: 0
25-02-12 07:01







   Web - программирование
PHP


ASP






XML



CSS

SSI





   Программирование под ОС











   Web - технологии








   Базы Данных









   Графика






Данные




Web - технологии / Сети /

Настройка маршрутизации между VLAN при помощи внешнего роутера

Транкинг это способ передачи трафика из нескольких VLAN по каналу связи типа точка-точка между двумя устройствами. Ethernet транкинг может быть реализован двумя способами: ISL (Собственный протокол Cisco и не поддерживаются свитчами 2940 и 2950 серий) и 802.1Q (стандарт IEEE)ю Мы создадим транк который будет переносить трафик от двух VLAN (VLAN1 и VLAN2) через единственный канал между Catalyst 3500 и роутером Cisco 2600. Мы используем маршрутизатор Cisco 2600, чтобы выполить маршрутизацию между VLAN (Inter-VLAN routing). Более подробно о том, что такое маршрутизация между VLAN можно посмотреть по ссылке Routing Between VLANs Overview официальной документации


В свитчах Catalyst 2900XL/3500XL/2940/2950/2970, интерфейс VLAN (int vlan1, int vlan2) может быть создан для каждого и только каждого VLAN который конфигурируется на свитче. Однако в одно и тоже время только один VLAN может быть использован для управления. IP адрес назначается только на интерфейс VLAN управления. Если IP адрес назначается для другого интерфейса VLAN, который не используется для управления, такой интерфейс не поднимется. Поэтому рекомендуется создавать только один VLAN для целей управления.
В методе 802.1Q один VLAN не тэгируется. Такой VLAN называется родным или native VLAN. Родной VLAN используется для не тэгированного трафика когда порт 802.1Q работает в режиме транка. Во время настройки транка 802.1Q важно помнить, что родной VLAN должен быть одним и тем же на каждой стороне транка. Одна из общих ошибок – это не соответствие родных VLAN при настройке транка 802.1Q между маршрутизатором и свитчом.

В этой конфигурации, родной VLAN это VLAN 1 по умолчанию и на Cisco2611 и на Catalyst 3512. В зависимости от дизайна вашей сети, родной VLAN может отличаться от VLAN1.
Сетевая диаграмма показана на рисунке:
 

Настройка маршрутизации между VLAN при помощи внешнего роутера


Настраиваем коммутатор Catalyst 3512XL

Создаем интерфейс VLAN 1 и назначим шлюз по умолчанию для целей управления

<!--code1-->
<!--ecode1-->3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end<!--code2-->
<!--ecode2-->

Установим VTP режим. В данном примере режим будет transparent.

<!--code1-->
<!--ecode1-->3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.<!--code2-->
<!--ecode2-->

Добавим VLAN2. VLAN1 уже существует по умолчанию.
<!--code1-->
<!--ecode1-->3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....
<!--code2-->
<!--ecode2-->

Включаем режим транкинга на интерфейсе fa0/1
<!--code1-->
<!--ecode1-->3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk<!--code2-->
<!--ecode2-->

Вводим режим инкапсуляции ISL
<!--code1-->
<!--ecode1-->3512xl(config-if)#switchport trunk encapsulation isl<!--code2-->
<!--ecode2-->

Либо для 802.1Q
<!--code1-->
<!--ecode1-->3512xl(config-if)#switchport trunk encapsulation dot1q<!--code2-->
<!--ecode2-->

В случае свитчей серий 2940/2950 ни одна из вышеприведенных команд не используется, т.к. эти свитчи поддерживают только режим 802.1Q, который включается по умолчанию, когда настраивается транкинг.

Будьте уверены, что родной VLAN по обе стороны транка одинаковый. Для 3512XL родной VLAN это VLAN1 по умочанию. Если вам надо использовать другой ”родной” VLAN, используйте команду
<!--code1-->
<!--ecode1-->3512xl(config-if)#switchport trunk native vlan <vlan ID><!--code2-->
<!--ecode2-->

Разрешаем все VLAN на транке
<!--code1-->
<!--ecode1-->3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit<!--code2-->
<!--ecode2-->

Следующие команды поместят порт fa0/2 в VLAN2
<!--code1-->
<!--ecode1-->3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit<!--code2-->
<!--ecode2-->

Порт fa0/3 уже находиться в VLAN1 по умолчанию
<!--code1-->
<!--ecode1-->3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z<!--code2-->
<!--ecode2-->

Сохраним конфигурацию
<!--code1-->
<!--ecode1-->3512xl#write memory
Building configuration...
<!--code2-->
<!--ecode2-->

Вот какая конфигурация получилась

<!--code1-->
<!--ecode1-->hostname 3512xl
!
interface FastEthernet0/1
  switchport mode trunk
  switchport trunk encapsulation dot1q
!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
spanning-tree portfast
!
!
interface VLAN1
ip address 10.10.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 10.10.10.1
!
end
<!--code2-->
<!--ecode2-->

Настраиваем маршрутизатор

Выбираем интерфейс fa0/0 для конфигурации транка.
<!--code1-->
<!--ecode1-->c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit
<!--code2-->
<!--ecode2-->

Создаем саб-интерфейс и настраиваем на нем транк. Заметим, что транк можно настроить только на саб-интерфейсах
<!--code1-->
<!--ecode1-->c2600(config)#int fastEthernet 0/0.1<!--code2-->
<!--ecode2-->

Вводим режим инкапсуляции ISL
<!--code1-->
<!--ecode1-->c2600(config-subif)#encapsulation isl 1<!--code2-->
<!--ecode2-->

или 802.1Q. В случае 802.1Q необходимо быть уверенным, что ”родной” VLAN настроен таким же как и на Catalyst 3512XL
<!--code1-->
<!--ecode1-->c2600(config-subif)#encapsulation dot1Q 1 native<!--code2-->
<!--ecode2-->

Настраиваем L3 информацию на саб-интерфейсе 0/0.1 или ip адрес, если кто не понял
<!--code1-->
<!--ecode1-->c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit
<!--code2-->
<!--ecode2-->

Выполняем аналогичные операции для настройки транкинга на интерфейсе fa0/0.2
<!--code1-->
<!--ecode1-->c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z
<!--code2-->
<!--ecode2-->

Сохраним конфигурацию
<!--code1-->
<!--ecode1-->c2600#write memory
Building configuration...
[OK]
c2600#
<!--code2-->
<!--ecode2-->

Для того, чтобы workstation1 могла обмениваться данными с workstation2, будьте уверены что шлюзы по умочанию на рабочих станциях установлены правильно. Для workstation1, шлюз по умолчанию должен быть 10.10.11.1, а для workstation2, шлюз по умолчанию должен быть 10.10.10.1

Вот какая конфигурация получилась на роутере

<!--code1-->
<!--ecode1-->hostname c2600
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation isl 1
ip address 10.10.10.1 255.255.255.0
no ip redirects
!
interface FastEthernet0/0.2
encapsulation isl 2
ip address 10.10.11.1 255.255.255.0
no ip redirects
!
end
<!--code2-->
<!--ecode2-->

По материалам: www.cisco.com

Источник: http://www.ciscolab.ru




Комментарии

 Ваш комментарий к данному материалу будет интересен нам и нашим читателям!



Последние статьи: Web - технологии / Сети /

Будущие интернет-каналы могут быть созданы на основе нанотрубок
30-01-2011   

Американские исследователи из Корнельского университета говорят, что углеродные нанотрубки способны передавать и принимать фотоны света в наномасштабах точно также, как радиостанции работают с радиоволнами.

... подробнее

Кол. просмотров: общее - 4253 сегодня - 2

Ботнет
15-03-2010   

В статье речь пойдет о том, что такое зомби-сети, или ботнеты, как они формируются, кто и как наживается с их помощью, а также о том, каковы тенденции развития ботнетов... подробнее

Кол. просмотров: общее - 3173 сегодня - 1

Как работает NAT
15-03-2010   

Если Вы читаете этот документ, то скорее всего вы подсоединены к Интернету, и используете трансляцию сетевых адресов (Network Address Translation, NAT) прямо сейчас! Интернет стал настолько огромным, чем кто-либо мог себе представить... подробнее

Кол. просмотров: общее - 3274 сегодня - 0

Построение безопасных сетей на основе VPN
15-03-2010   

В современных условиях развития информационных технологий, преимущества создания виртуальных частных сетей неоспоримы. Но прежде чем перечислить наиболее очевидные и полезные способы организации виртуальных частных сетей... подробнее

Кол. просмотров: общее - 3524 сегодня - 3

NAS – сетевая система хранения данных
15-03-2010   

NAS (англ. Network Attached Storage) – сетевая система хранения данных. Сетевые хранилища представляют собой внешние жёсткие диски... подробнее

Кол. просмотров: общее - 3076 сегодня - 0



  WWW.COMPROG.RU - 2009-2012 | Designed and Powered by Zaipov Renat | Projects