[ главная ]   [ рейтинг статей ]   [ справочник радиолюбителя ]   [ новости мира ИТ ]



Ответов: 0
25-02-12 07:01







   Web - программирование
PHP


ASP






XML



CSS

SSI





   Программирование под ОС











   Web - технологии








   Базы Данных









   Графика






Данные




Web - технологии / Сети /

Базовая конфигирация OSPF на Ethernet

Данный документ объясняет как конфигурировать протокол динамической маршрутизации Open Shortest Path First (OSPF) на широковещательной (broadcast) среде, такой как Ethernet и Token Ring. Для ознакомления с протоколом OSPF и его работой рекомендуется обратится к статье Введение в протокол OSPF, а также к документу Состояния OSPF соседа ранее опубликованных на CiscoLAB

В этой статье используется следующая сетевая диаграмма

 
Базовая конфигирация OSPF на Ethernet


Два маршрутизатора Router1 и Router2 подключены к сетевой среде Ethernet своими интерфейсами на которые назначены IP адреса 10.10.10.1/24 и 10.10.10.2/24 соотвественно.

Конфигурация Router1

<!--code1-->
<!--ecode1-->interface Loopback0
ip address 192.168.45.1 255.255.255.0
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
!

!--- Протокол OSPF настроен для работы на интерфейсе Ethernet c Area ID  0.
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
!
<!--code2-->
<!--ecode2-->


Конфигурация Router2
<!--code1-->
<!--ecode1-->interface Loopback0
ip address 172.16.10.1 255.255.255.0
!
interface Ethernet0
ip address 10.10.10.2 255.255.255.0
!
!--- Протокол OSPF настроен для работы на интерфейсе Ethernet c Area ID  0.
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
!
<!--code2-->
<!--ecode2-->

Команда show ip ospf neighbor покажет нам информацию об OSPF-соседях.

<!--code1-->
<!--ecode1-->Router1#show ip ospf neighbor

Neighbor ID   Pri    State          Dead Time      Address       Interface
172.16.10.1    1     FULL/BDR       00:00:38     10.10.10.2      Ethernet0
<!--code2-->
<!--ecode2-->

Из этого вывода видно, что состояние соседа является FULL на роутере Router1 по отношению к Router2, который имеет Neighbor ID 172.16.10.1. Router2 - это резервный роутер (Backup Designated Router, BDR) в этой широковещательной сети.

Команда show ip ospf interface покажет разнообразную информацию связанную с OSPF интерфейсом. Выполним ее на Router1

<!--code1-->
<!--ecode1-->Router1#show ip ospf interface ethernet 0
   Ethernet0 is up, line protocol is up
   Internet Address 10.10.10.1/24, Area 0
   Process ID 1, Router ID 192.168.45.1, Network Type BROADCAST, Cost: 10
   Transmit Delay is 1 sec, State DR, Priority 1
   Designated Router (ID) 192.168.45.1, Interface address 10.10.10.1
   Backup Designated router (ID) 172.16.10.1, Interface address 10.10.10.2
<!--code2-->
<!--ecode2-->

Из этого вывода мы видим, что типом сети для интрефейса Ethernet0 является BROADCAST



Комментарии

 Ваш комментарий к данному материалу будет интересен нам и нашим читателям!



Последние статьи: Web - технологии / Сети /

Будущие интернет-каналы могут быть созданы на основе нанотрубок
30-01-2011   

Американские исследователи из Корнельского университета говорят, что углеродные нанотрубки способны передавать и принимать фотоны света в наномасштабах точно также, как радиостанции работают с радиоволнами.

... подробнее

Кол. просмотров: общее - 4325 сегодня - 1

Ботнет
15-03-2010   

В статье речь пойдет о том, что такое зомби-сети, или ботнеты, как они формируются, кто и как наживается с их помощью, а также о том, каковы тенденции развития ботнетов... подробнее

Кол. просмотров: общее - 3228 сегодня - 2

Как работает NAT
15-03-2010   

Если Вы читаете этот документ, то скорее всего вы подсоединены к Интернету, и используете трансляцию сетевых адресов (Network Address Translation, NAT) прямо сейчас! Интернет стал настолько огромным, чем кто-либо мог себе представить... подробнее

Кол. просмотров: общее - 3339 сегодня - 1

Построение безопасных сетей на основе VPN
15-03-2010   

В современных условиях развития информационных технологий, преимущества создания виртуальных частных сетей неоспоримы. Но прежде чем перечислить наиболее очевидные и полезные способы организации виртуальных частных сетей... подробнее

Кол. просмотров: общее - 3610 сегодня - 1

NAS – сетевая система хранения данных
15-03-2010   

NAS (англ. Network Attached Storage) – сетевая система хранения данных. Сетевые хранилища представляют собой внешние жёсткие диски... подробнее

Кол. просмотров: общее - 3132 сегодня - 2



  WWW.COMPROG.RU - 2009-2012 | Designed and Powered by Zaipov Renat | Projects